Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 10:00 UTC
Scheduled
Scheduled Maintenance Notice: Date: Tuesday 25th March 2025 Time: 10:00 - 12:00 UTC Additional notes: This is routine and essential maintenance for OT&E and Testbed to ensure continued reliability and security of our services. If the table below is not loading correctly, please ensure you visit: Planned Maintenance Notice System TLDs 2025-03-25 10:00 - 12:00 UTC EPP .UK ccTLD ✔ gTLDs ✔ WHOIS .UK ccTLD ✔ gTLDs ✔ RDAP .UK ccTLD ✔ gTLDs ✔ Web Domain Manager .UK ccTLD ✔ gTLDs ✔ Online Services .UK ccTLD ✔ gTLDs ✔ Searchable WHOIS .UK ccTLD ✔ gTLDs ✔ Domain Availability Checker (DAC) .UK ccTLD ✔ Business Intelligence .UK ccTLD ✔ Operational Test & Evaluation (OT&E) .UK ccTLD ✘ gTLDs ✘ Testbed .UK ccTLD ✘ gTLDs ✘ DNS .UK ccTLD ✔ gTLDs ✔ APIs .UK ccTLD ✔ Key Meaning ✘ Systems unavailable, connections could be reset TBC To be confirmed in 7 day notice ✔ Working as normal
Posted Mar 19, 2025 - 06:59 UTC
This scheduled maintenance affected: Domain Services (Other ccTLDs).